WordPress FAQ – 코어 또는 테마를 설치할 때 오류메시지가 나옵니다.

워드프레스 한국어판 설치하는 과정에서 다음 오류를 보았습니다.

�떦�떊�쓽 �꽌踰꾨뒗 PHP 踰꾩쟾 5.0.4瑜� �궗�슜以묒엯�땲�떎留� �썙�뱶�봽�젅�뒪 3.2.1�?(�뒗) 理쒖냼 5.2.4 �씠�긽�쓣 �슂援ы빀�땲�떎.

한글 깨짐 현상과 정상적으로 구동하지 않는 이유를 알고 싶습니다.

워드프레스를 서버에 올렸는데 버전이 맞지않아 실행이 되지 않는듯 합니다.
Your server is running PHP version 4.4.9 but WordPress 3.6 requires at least 5.2.4.
서버는 php 4.4.9 인데 워드프레스가 작동 되려면 어떤 버전을 받아야 하나요?

답변 :
WordPress 는 3.0 이후로는 UTF-8 인코딩만 사용하여 배포하고 있습니다.
위 메시지는 서버설정에 의해 강제로 EUC-KR 인코딩으로 변환되어 보여진 결과입니다.
정상적인 메시지는 다음과 같습니다.

사용 중인 서버는 PHP 5.0.4를 이용 중입니다. 워드프레스 3.2.1 버전은 최소 5.2.4 버전 이상을 요구합니다.

입니다. 이 질문을 하셨던 분은 Apache 2.0.64, PHP 5, MySQL 4.0.24, WordPress 3.2.1을 이용하신다고 알려주셨습니다.
이에 대한 답변으로 Apache 2.2 이상, PHP 5.3.10 이상, MySQL 5.1 이상을 사용하는 서버로 이동하여 설치할 수 있도록 안내하였습니다.

본 게시물 작성 시점 기준으로 설치시 요구사항은 Apache 2.4 이상, PHP 5.2.4 이상, MySQL 5.0 이상이 필요합니다.
PHP는 현재 5.5.9, 5.4.25, 5.3.28 버전을 사용할 것을 요구하고 있으며 5.5를 설치하여 사용할 것을 권장하고 있습니다.
MySQL은 현재 5.6.16 버전이 최신버전이며 5.5 이상 설치할 것을 요구하고 있습니다.